Running getid for trial license on Mac OSX

Discussion in 'MuJoCo Pro Bug Reports' started by arbitrary, Aug 17, 2016.

  1. Hi! I know this is a hopelessly lame question, but I'm completely stuck... how do I run the getid executable to get a free trial? When I run it in terminal it gives me a command not found error.

    Thanks!
     
  2. Emo Todorov

    Emo Todorov Administrator Staff Member

    ./getid_osx instead of just getid_osx perhaps?

    Assuming the file getid_osx is in the current directory...
     
  3. Ah, it was something else -- I needed to chmod the file permissions. Sorry to bug you!
     
  4. I'm not able to run the getid_osx. I get this error on my mac

    (py3) MM-MAC-3358:Downloads pchalasani$ ls -al ./getid_osx
    -rwxr-xr-x@ 1 root wheel 14345 Sep 30 09:39 ./getid_osx

    (py3) MM-MAC-3358:Downloads pchalasani$ ./getid_osx
    -bash: ./getid_osx: cannot execute binary file
     
  5. It looks like this is not a mac osx executable
     
  6. Emo Todorov

    Emo Todorov Administrator Staff Member

    It is definitely an executable; everyone using the software on Mac has been able to run it... what OS version are you using?
     
  7. something was wrong with the sequence in which I was downloading, changing permissions, etc.

    I re-did and all is good, thanks
     
  8. Hi Emo,

    I have a mac machine. Can you please give some clue on how to run "getid_osx" to get the computer id?

    dyn-160-39-8-254:Downloads $ sudo ./getid_osx

    sudo: ./getid_osx: command not found

    dyn-160-39-8-254:Downloads $ ./getid_osx

    -bash: ./getid_osx: Permission denied
     
  9. Emo Todorov

    Emo Todorov Administrator Staff Member

    Use 'chmod' to give getid_osx execute permission, and then run it.
     
  10. thanks. the following code works for me.



    dyn-160-39-8-254 Downloads $ chmod -f 711 getid_osx

    dyn-160-39-8-254 Downloads $ ./getid_osx