Problem capturing Video in mujoco

Discussion in 'Support requests' started by Nihar S Talele, May 15, 2019.

  1. Hi,
    I was trying to capture a video in mujoco but I am getting a shadow image in the video. I have attached some frames for reference. Any idea what might be causing this and how I could rectify this?

    Edit: I am running mujoco v1.5 on ubuntu 16.04. Also, the shadow image only appears when I try to capture a video or a frame. It does not appear when I'm just visualizing the model

    Thank You,

    Attached Files:

    Last edited: May 15, 2019
  2. Emo Todorov

    Emo Todorov Administrator Staff Member

    Strange. The "shadows" look like reflections... could it be that you have defined a reflective plane and have reflections enabled? Or perhaps something to do with stereo rendering?

    Another possibility is some low-level pixels transfer operation, resulting in pixels being replicated/misaligned/interlaced. But that would result in identical images or a complete mess, while your shadows have somewhat different shape, suggesting they are the result of rendering and not a pixel transfer bug.
  3. It doesn't look like a problem with my model. I tried the example model files as well and they all have "shadow images" when I record. Again, the problem only exists when I try to record something. The visualization by itself works fine.
    I also tried to test the record.cpp by running
    ./record humanoid.xml 5 60 rgb.out
    to test it out and it gives me a segmentation fault.
  4. Emo Todorov

    Emo Todorov Administrator Staff Member

    If record is crashing, that means there is something unusual with your video drivers/system. What are you using to create an offscreen OpenGL context -- EGL, Mesa or X11? Try to recompile the code sample record.cpp on the same system and see if it still crashes. You can do that with the makefile in the samples directory.