getid_win64 exits without any outputs

Discussion in 'Licensing and activation' started by Pandora Box, Jan 20, 2019.

  1. Hi,

    I am currently using Ubuntu 16.04. And I want to use MuJoCo in Windows 10 on a VMware Workstation virtual machine. When I use getid_win64 to retrieve computer id of windows 10, it just exits without any outputs. I run it in an admin shell, it shows "could not query drive". How to resolve this problem?

    Thanks in advance.
     
  2. Emo Todorov

    Emo Todorov Administrator Staff Member

    This means that the license manager will not work on your system. That is unusual, I have been able to run it on Ubuntu in VMware... but I guess something about your system is different and the way MuJoCo obtains hardware information is not working.
     
  3. Thank you for the reply.

    The reason I need windows is I need to run MuJoCo in Matlab. Are you planning to release the code for Matlab on Linux? That will also solve my problem...
     
  4. Emo Todorov

    Emo Todorov Administrator Staff Member

    If you run everything in Windows (MATLAB and MuJoCo) it will work. But if MATLAB is running in Windows while MuJoCo is runing in a Linux VM, I don't see how that helps you even if the VM worked...

    The MATLAB wrapper is a code sample available in the distribution. You can try to make it work on Linux. I tried briefly and there were mysterious crashes, possibly because of compiler/library version incompatibilities, so I gave up.